Emerging BJC Service Outage: Misc Applications
Incident Report for Washington University - IT
Resolved
WashU IT Engineers have resolved the issue.

If you continue to experience further issues, please contact us at 314-933-3333.
Posted Mar 28, 2024 - 21:46 CDT
Update
WashU IT has implemented a workaround to restore services.

Teams are monitoring infrastructure health and reviewing root-cause.
Posted Mar 28, 2024 - 18:55 CDT
Investigating
WashU IT and BJC IT are investigating reports of issues with various services.

Users may receive error messages or inability to log into services, including Epic.
Posted Mar 28, 2024 - 18:37 CDT
This incident affected: Clinical (EPIC, Clinical Websites).