Partial Service Outage: PC Network Connectivity - BJC South County Locations
Incident Report for Washington University - IT
Resolved
WashU IT Engineers have resolved the issue with PC network connectivity. If you continue to experience further issues, please contact us at 314-933-3333.

We appreciate your patience during this incident.
Posted Apr 24, 2024 - 11:55 CDT
Investigating
WashU IT is investigating an issue with a small number of PC's at the BJC South County campus. The issue is causing PC's to frequently disconnect from the network. Wireless is available as a workaround.

Teams are working to resolve the issue. Please call 314-933-3333 if you have any questions.

We appreciate your patience as we work to restore service.
Posted Apr 24, 2024 - 09:28 CDT
This incident affected: Computing and Printing (Desktop Computing).