Service Outage: Spectrum Network - 22 North Euclid
Incident Report for Washington University - IT
Resolved
Spectrum has resolved the fiber optic issue at 22 North Euclid.

If you continue to experience further issues, please contact us at 314-933-3333.

We appreciate your patience during this incident.
Posted Apr 25, 2024 - 15:30 CDT
Update
Spectrum is on-site and performing fiber optic repairs, which are expected to last throughout the evening.
Posted Apr 25, 2024 - 11:53 CDT
Identified
Washington University IT has identified a Spectrum outage at 22 North Euclid affecting network services.

Spectrum is aware and working to resolve the issue.
Posted Apr 25, 2024 - 08:04 CDT
This incident affected: Network & Connectivity (Internet).