Vendor Service Degradation: Microsoft 365 Services
Incident Report for Washington University - IT
Resolved
Microsoft Engineers have resolved the issues with Microsoft 365 services. If you continue to experience further issues, please contact us at 314-933-3333.

We appreciate your patience during this incident.
Posted Jun 05, 2023 - 20:28 CDT
Investigating
WashU IT is aware of a global vendor issue with Microsoft 365 services. Users may see slow performance or degradation on Outlook, Teams, Sharepoint, OneDrive, and Office 365.

Microsoft is working to resolve the issue. Please call 314-933-3333 if you have any questions. We appreciate your patience.
Posted Jun 05, 2023 - 18:30 CDT
This incident affected: Communications & Collaboration (Email, Office 365, Microsoft Teams).