Vendor Service Outage: Spectrum Internet at ParaQuad Building
Incident Report for Washington University - IT
Resolved
Spectrum Engineers have completed the restoration effort. All services have been restored.
Posted Jul 06, 2024 - 04:47 CDT
Identified
Spectrum has identified the root cause as fiber damage affecting many customers.

Crews are on-site and splicing fiber to restore services.
Posted Jul 05, 2024 - 22:25 CDT
Investigating
WashU IT is aware of an issue with Spectrum Internet affecting the ParaQuad building.

WashU IT has opened a ticket with the vendor who is aware of the issue.

Please call 314-933-3333 if you have any questions. We appreciate your patience as we work to restore service.
Posted Jul 05, 2024 - 15:57 CDT
This incident affected: Network & Connectivity (Internet, Network Services).