BJC Service Outage: Data flows into EPIC
Incident Report for Washington University - IT
Resolved
BJC IT Engineers have resolved the issue with data flows into EPIC. If you continue to experience further issues, please contact us at 314-933-3333.

We appreciate your patience during this incident.
Posted Sep 13, 2021 - 16:48 CDT
Investigating
BJC IT is investigating reports of an issue with data flows into EPIC.

Please call 314-933-3333 if you have any questions. We appreciate your patience as BJC works to restore service.
Posted Sep 13, 2021 - 16:09 CDT
This incident affected: BJC Devices and Services (BJC Clinical Applications).