Vendor Service Outage: Confluence Cloud
Incident Report for Washington University - IT
Resolved
Atlassian has resolved the issues with Confluence Cloud.

If you continue to experience further issues, please contact us at 314-933-3333.
Posted Mar 26, 2024 - 12:10 CDT
Update
Services appear to be recovering for some users, and appear to be slow for others.

The vendor still has not identified root cause and is still working to resolve the issue.
Posted Mar 26, 2024 - 10:28 CDT
Investigating
WashU IT is aware of an outage of the vended Confluence Cloud platform. Atlassian is aware of the issue and working to resolve it.
Posted Mar 26, 2024 - 08:51 CDT
This incident affected: Vendor Service.