The Canvas vendor and Amazon Web Services have resolved the technical issue which was impacting Canvas. If you continue to experience further issues, please contact us at 314-933-3333.
We appreciate your patience during this incident.
NOTE: This outage was incorrectly listed on our Status Page as a Box Storage outage; there was no impact to Box Storage during this time.
Posted Jul 16, 2026 - 07:26 CDT
Monitoring
The Canvas vendor has been working with Amazon Web Services to resolve the service issue affecting Canvas. Potential fixes for the issues have been implemented and the vendor is monitoring to ensure full recovery. Teams are continuing to monitoring the service. If you continue to experience further issues, please contact us at 314-933-3333.
We appreciate your patience during this incident.
NOTE: This outage was incorrectly listed on our Status Page as a Box Storage outage; there was no impact to Box Storage during this time.
Posted Jul 16, 2026 - 07:10 CDT
Update
WashU IT is investigating an issue with Canvas. The vendor has acknowledged a service outage on their status page (https://status.instructure.com/).
Please call 314-933-3333 if you have any questions.
Posted Jul 16, 2026 - 03:36 CDT
Investigating
WashU IT is investigating an issue with Canvas. The vendor has acknowledged a service outage on their status page (https://status.instructure.com/).
Please call 314-933-3333 if you have any questions.
Posted Jul 16, 2026 - 03:33 CDT
This incident affected: Teaching & Learning (Canvas).