Service Outage (Vendor) - High Severity: Spectrum Network Outage @ Multiple Sites

Incident Report for Washington University - IT

Resolved

WashU IT has confirmed that Spectrum has restored Internet service with full redundancy to affected sites. If you continue to experience further issues, please contact us at 314-933-3333.

We appreciate your patience during this incident.
Posted Sep 01, 2026 - 20:05 CDT

Monitoring

WashU IT has confirmed that network and internet connectivity is coming back online at the affected sites. Technical teams will continue to monitor the environment while working with the vendor to ensure stable services. If you continue to experience further issues, please contact us at 314-933-3333.

We appreciate your patience during this incident.
Posted Sep 01, 2026 - 18:03 CDT

Identified

WashU IT has received reports of a Spectrum network outage which is affecting BJC West Physician's Buildings 1, 2 and 3. Other sites are also likely to be impacted, but details are still being investigated. A support case has been opened with Spectrum and they are dispatching a repair team this evening to resolve the issue.

Other sites which may be impacted:
• 450 New Ballas Rd. (Ophthalmology and Oto clinics)
• Southwest Pediatrics
• Village Square Crossing
• 7101 N Lindberg Blvd and 1 Village Square Shopping Center
• Northwest Pediatrics - St. Charles
• WUCA Balance Care Center
• Northwest Pediatrics - Wentzville
• WUCA OT clinic at 1629 A. Roy Dr. Washington MO
• Progress Point Parkway
• 535-555 N. New Ballas Road

Please call 314-933-3333 if you have any questions. We appreciate your patience as we work to restore service.
Posted Sep 01, 2026 - 16:12 CDT

Investigating

WashU IT has received reports of a Spectrum network outage which is affecting BJC West Physician's Buildings 1, 2 and 3. Other sites are also likely to be impacted, but details are still being investigated. A support case has been opened with Spectrum and they are dispatching a repair team this evening to resolve the issue.

Please call 314-933-3333 if you have any questions. We appreciate your patience as we work to restore service.
Posted Sep 01, 2026 - 15:32 CDT
This incident affected: Network & Connectivity (Vendor Services (Spectrum, AT&T, etc.)).