Service Outage - High Severity: Citrix Missing After Window Upgrade

Incident Report for Washington University - IT

Resolved

Service Desk call volume following the issue in which Citrix is no longer installed after remote devices on VPN performed the upgrade to 25H2 has subsided to baseline.

We appreciate your patience during this incident.
Posted Sep 22, 2026 - 16:35 CDT

Update

Washington University IT continues to address the issue in which Citrix is no longer installed after remote devices on VPN performed the upgrade to 25H2. Affected machines require that Citrix be reinstalled. The Service Desk has cleared their call queue but the incident remains open while they are still receiving calls about it.

Users can self-install Citrix via Software Center by searching for Citrix in Software Center and selecting Citrix Workspace. (Note: the machine must be connected via VPN and a restart is required.)

If Software Center shows an Uninstall option for Citrix workspace then please Navigate to Citrix in the lower corner of your desktop Right click on the Citrix icon Select Refresh

Teams are working to resolve the issue. Please call 314-933-3333 if you have any questions. We appreciate your patience as we work to restore service.
Posted Sep 22, 2026 - 12:33 CDT

Identified

Washington University IT has identified the cause of the issue in which Citrix is no longer installed after remote devices on VPN performed the upgrade to 25H2. Affected machines require that Citrix be reinstalled. The Service Desk continues to work through their call queue. Users can self-install Citrix via Software Center by searching for Citrix in Software Center and selecting Citrix Workspace. (Note: the machine must be connected via VPN and a restart is required.)

If Software Center shows an Uninstall option for Citrix workspace then please Navigate to Citrix in the lower corner of your desktop Right click on the Citrix icon Select Refresh

Teams are working to resolve the issue. Please call 314-933-3333 if you have any questions. We appreciate your patience as we work to restore service.
Posted Sep 22, 2026 - 10:44 CDT

Update

WashU IT is investigating reports of Citrix no longer being installed after remote devices upgrade to 25H2. Reinstalling Citrix via Software Center is working in most cases. Users can self-install Citrix via Software Center by searching for Citrix in Software Center and selecting Citrix Workspace. (Note: the machine must be connected via VPN and a restart is required.)

If Software Center shows an Uninstall option for Citrix workspace then please Navigate to Citrix in the lower corner of your desktop Right click on the Citrix icon Select Refresh

Teams are working to resolve the issue. Please call 314-933-3333 if you have any questions. We appreciate your patience as we work to restore service.
Posted Sep 22, 2026 - 09:16 CDT

Investigating

WashU IT is investigating reports of Citrix no longer being installed after remote devices upgrade to 25H2. Reinstalling Citrix via Software Center is working in most cases.

Teams are working to resolve the issue. Please call 314-933-3333 if you have any questions. We appreciate your patience as we work to restore service.
Posted Sep 22, 2026 - 07:43 CDT
This incident affected: Clinical Applications (ECV (Enterprise Client Virtualization)).