Service Outage - Low Severity: Delayed Mulesoft Processing

Incident Report for Washington University - IT

Resolved

WashU IT Engineers have confirmed that the backlog of Mulesoft data has finished being processed. If you continue to experience further issues, please contact us at 314-933-3333.

We appreciate your patience during this incident.
Posted Mar 03, 2026 - 17:22 CST

Update

WashU IT continues to troubleshoot the issues affecting Mulesoft processing. A backlog of records updates is still being processed, but at this time we believe all account changes have been applied and are current. Teams are continuing to monitoring the service. If you continue to experience further issues, please contact us at 314-933-3333.

We appreciate your patience during this incident.
Posted Mar 03, 2026 - 15:29 CST

Investigating

WashU IT is investigating an issue with slow performance in Mulesoft. This will cause delays to processing of account changes, including new user accounts and self-service account changes in Workday.

Teams are working to resolve the issue. Please call 314-933-3333 if you have any questions. We appreciate your patience as we work to restore service.
Posted Mar 03, 2026 - 13:13 CST
This incident affected: Administrative & Enterprise Systems (Mulesoft).