Service Outage - Low Severity: ServiceNow Integration w/ BJC

Incident Report for Washington University - IT

Resolved

The issue affecting the ServiceNow integration with BJC has been resolved. If you continue to experience further issues, please contact us at 314-933-3333.

We appreciate your patience during this incident.
Posted Apr 24, 2026 - 16:10 CDT

Update

WashU IT is investigating an issue with our ServiceNow integration with BJC. Incidents sent between the WashU and BJC SNow instances may not stay connected or may generate duplicate Incident numbers. The issue has been traced to a recently implemented change, and technical teams from both WashU and BJC are troubleshooting the issue.

Teams are working to resolve the issue. Please call 314-933-3333 if you have any questions. We appreciate your patience as we work to restore service.
Posted Apr 24, 2026 - 15:17 CDT

Investigating

WashU IT is investigating an issue with our ServiceNow integration with BJC. Incidents sent between the WashU and BJC SNow instances may not stay connected or may generate duplicate Incident numbers.

Teams are working to resolve the issue. Please call 314-933-3333 if you have any questions. We appreciate your patience as we work to restore service.
Posted Apr 24, 2026 - 13:09 CDT
This incident affected: IT Management (ServiceNow).