Vendor Service Outage: Spectrum Outage at 5615 Pershing Avenue

Incident Report for Washington University - IT

Resolved

Spectrum Engineers have resolved the issue which was attributed to a failed hardware component in Spectrum's infrastructure.

If you continue to experience further issues, please contact us at 314-933-3333.

We appreciate your patience during this incident.
Posted Mar 11, 2025 - 10:50 CDT

Identified

Spectrum has arrived on site and testing fiber optics for the site.
Posted Mar 11, 2025 - 10:16 CDT

Investigating

WashU IT is aware of a Spectrum Outage at 5615 Pershing Avenue.

Spectrum is working to resolve the issue. Please call 314-933-3333 if you have any questions.

We appreciate your patience as Spectrum works to restore service.
Posted Mar 11, 2025 - 06:50 CDT
This incident affected: Network & Connectivity (Vendor Services (Spectrum, AT&T, etc.)).