BJC Service Outage: Telephony Issues

Incident Report for Washington University - IT

Resolved

BJC has resolved the issue affecting telephony services. If you continue to experience further issues, please contact us at 314-933-3333.

We appreciate your patience during this incident.
Posted Feb 12, 2026 - 17:02 CST

Update

BJC is continuing to work with the vendor to resolve the issue.
Posted Feb 12, 2026 - 14:34 CST

Investigating

WashU IT is aware of an issue with BJC Telephony Services that is causing some calls to drop from the following locations:

BJWC, Mason Ridge, Home Health, Hospice, Edwardsville, CAM, Orthopedic Center, Commons, MBMC, Imperial Medical Group, WashU Sites, and multiple Call Centers.

BJC is working with the vendor to resolve the issue.
Posted Feb 12, 2026 - 13:19 CST
This incident affected: BJC Devices and Services (BJC Telephony and Fax).