Service Outage - Low Severity: Northwest Tower Wired Network Issue

Incident Report for Washington University - IT

Resolved

WashU IT Engineers have resolved the issue affecting ethernet connectivity for Suite 1260. The issue was due to a migration away from using desk phones and was resolved by plugging the computers directly into the ethernet port. If you continue to experience further issues, please contact us at 314-933-3333.

We appreciate your patience during this incident.
Posted Sep 25, 2026 - 09:01 CDT

Investigating

WashU IT is investigating an issue with multiple users in Suite 1260 at Northwest Tower losing wired ethernet network connectivity. Wireless network connectivity still works as an alternative.

Teams are working to resolve the issue. Please call 314-933-3333 if you have any questions. We appreciate your patience as we work to restore service.
Posted Sep 25, 2026 - 08:40 CDT
This incident affected: Network & Connectivity (Wired Network Services).