Service Outage: Ameren Service at Multiple Danforth Buildings

Incident Report for Washington University - IT

Update

Ameren is continuing to assess the situation and has no repair ETA published at this time.
Posted Aug 03, 2026 - 09:47 CDT

Monitoring

Service Outage: WashU IT is aware of an outage of Ameren Services at Multiple Danforth Buildings.

Ameren has confirmed the issue and has provided an estimated time of resolution at 9:15 AM.

We appreciate your patience as Ameren works to restore service.
Posted Aug 03, 2026 - 06:32 CDT
This incident affects: Facilities - Power, Water, Etc.