Service Degradation: Delayed email notifications from RMS

Incident Report for Washington University - IT

Resolved

WashU IT Engineers have resolved the RMS delayed email notifications problem. If you continue to experience further issues, please contact us at 314-933-3333.

We appreciate your patience during this incident.
Posted Mar 09, 2026 - 15:57 CDT

Update

We are continuing to monitor for any further issues.
Posted Mar 09, 2026 - 15:56 CDT

Update

WashU IT continues to monitor the delivery of email notifications from RMS. Thus far there are no reports of delayed email notifications.
Posted Mar 09, 2026 - 10:05 CDT

Monitoring

WashU IT has introduced a possible fix for the delayed email notifications in RMS. Teams are continuing to monitoring the service. If you continue to experience further issues, please contact us at 314-933-3333.

We appreciate your patience during this incident.
Posted Mar 06, 2026 - 15:34 CST

Investigating

WashU IT has been monitoring RMS email notification performance subsequent to the vendor's corrective measures, but users are still seeing delayed notification delivery. We continue to investigate.

Teams are working to resolve the issue. Please call 314-933-3333 if you have any questions. We appreciate your patience as we work to restore service.
Posted Mar 06, 2026 - 12:30 CST

Monitoring

The vendor that supports the RMS application has applied a corrective measure and emails are starting to arrive in a timely manner. Teams are continuing to monitoring the service. If you continue to experience further issues, please contact us at 314-933-3333.

We appreciate your patience during this incident.
Posted Mar 06, 2026 - 12:02 CST

Investigating

WashU IT is investigating an issue with RMS in which email notifications are delayed.

Teams are working to resolve the issue. Please call 314-933-3333 if you have any questions. We appreciate your patience as we work to restore service. [Select components below that are relevantly affected]
Posted Mar 06, 2026 - 11:00 CST
This incident affected: Research (RMS (Research Management System)).