BJC Service Outage: East Region Phone Calls

Incident Report for Washington University - IT

Resolved

BJC and AT&T have resolved the issues affecting phone calls in the East Region. If you continue to experience further issues, please contact us at 314-933-3333.

We appreciate your patience during this incident.
Posted Apr 15, 2026 - 18:04 CDT

Investigating

BJC is investigating reported issues with both inbound and outbound phone calls at multiple locations in the East Region.

Teams are working to resolve the issue. Please call 314-933-3333 if you have any questions. We appreciate your patience as we work to restore service.
Posted Apr 15, 2026 - 12:34 CDT
This incident affected: BJC Devices and Services (BJC Telephony and Fax).