Some users' outbound email messages may be delayed by two hours or rejected
Incident Report for Washington University - IT
Resolved
Microsoft has resolved the issue which only affected a small number of users.
Posted Mar 15, 2024 - 14:05 CDT
Monitoring
Microsoft has informed WashU that they are currently experiencing an issue in which some users' sent email messages are delayed by two hours or are rejected in Exchange Online.

Microsoft is working to isolate the root cause and determine their next steps.
Posted Mar 14, 2024 - 09:46 CDT
This incident affected: Communications & Collaboration (Email).