Vendor Outage: GrubHub unable to process BearBucks
Incident Report for Washington University - IT
Resolved
The vendor has resolved the Grub Issue If you continue to experience further issues, please contact us at 314-933-3333.

We appreciate your patience during this incident.
Posted Sep 13, 2021 - 16:08 CDT
Investigating
WashU IT is aware of an issue with GrubHub being unable to process BearBucks. GrubHub kiosks and app are unable to process BearBucks.

GrubHub is working to resolve the issue. Please call 314-933-3333 if you have any questions. We appreciate your patience as GrubHub works to restore service.
Posted Sep 02, 2021 - 10:26 CDT