Vendor Service Outage: Workday

Incident Report for Washington University - IT

Resolved

Workday has resolved the issue affecting their services. If you continue to experience further issues, please contact us at 314-933-3333.

We appreciate your patience during this incident.
Posted May 04, 2026 - 19:21 CDT

Update

WashU IT has received reports that Workday is inaccessible. The Workday vendor continues working to fully restore services.

Teams are working to resolve the issue. Please call 314-933-3333 if you have any questions. We appreciate your patience as we work to restore service.
Posted May 04, 2026 - 18:00 CDT

Update

WashU IT has received reports that Workday is inaccessible. The Workday vendor has continued to work on resolving the issue and has at least partially restored services, but users may experience slow response times.

Teams are working to resolve the issue. Please call 314-933-3333 if you have any questions. We appreciate your patience as we work to restore service.
Posted May 04, 2026 - 17:01 CDT

Investigating

WashU IT has received reports that Workday is inaccessible. The Workday vendor has posted acknowledgment that they are experiencing a service outage in one of their data centers.

Teams are working to resolve the issue. Please call 314-933-3333 if you have any questions. We appreciate your patience as we work to restore service.
Posted May 04, 2026 - 15:48 CDT
This incident affected: Administrative & Enterprise Systems (Workday).