Service Outage (Vendor) - High Severity: Box Service Degradation
Incident Report for Washington University - IT
Resolved
WashU IT has received confirmation from Box Support that the service degradation has been resolved. If you continue to experience further issues, please contact us at 314-933-3333.

We appreciate your patience during this incident.
Posted Jun 01, 2023 - 14:56 CDT
Investigating
WashU IT has received notification from Box Support indicating that they are experiencing a service degradation. Users may experience delays or error messages when logging into Box or trying to access files.

Please call 314-933-3333 if you have any questions.
Posted Jun 01, 2023 - 14:40 CDT
This incident affected: Communications & Collaboration (Box File Storage System).