Service Degradation (Vendor) - Low Severity: Workday Home Screen

Incident Report for Washington University - IT

Postmortem

A post-incident report is now available for this incident.
https://wustl.box.com/s/otvik8dbr3puf6q8kudmr0eu3rfjypy4

Posted Aug 25, 2026 - 09:58 CDT

Resolved

WashU IT Engineers have received confirmation from the vendor that they've resolved the service interruption on their platform. If you continue to experience further issues, please contact us at 314-933-3333.

We appreciate your patience during this incident.
Posted Aug 24, 2026 - 11:17 CDT

Update

WashU IT is investigating an issue with the Workday application main screen intermittently loading or showing error messages. The vendor is still working to fully restore services.

Teams are working to resolve the issue. Please call 314-933-3333 if you have any questions. We appreciate your patience as we work to restore service.
Posted Aug 24, 2026 - 09:57 CDT

Identified

WashU IT is investigating an issue with the Workday application main screen intermittently loading or showing error messages. The vendor has acknowledged a service issue on their end and they are working to restore service.

Teams are working to resolve the issue. Please call 314-933-3333 if you have any questions. We appreciate your patience as we work to restore service.
Posted Aug 24, 2026 - 08:53 CDT

Investigating

WashU IT is investigating an issue with the Workday application main screen taking a long time to load and eventually getting an error that something went wrong. Initial information indicates that the Workday vendor is experiencing a service degradation.

Teams are working to resolve the issue. Please call 314-933-3333 if you have any questions. We appreciate your patience as we work to restore service.
Posted Aug 24, 2026 - 07:58 CDT
This incident affected: Administrative & Enterprise Systems (Workday).