WashU IT Engineers have confirmed that Ameren restored power to the building and Monarch Pediatrics is back online. If you continue to experience further issues, please contact us at 314-933-3333.
We appreciate your patience during this incident.
Posted May 20, 2026 - 08:18 CDT
Investigating
WashU IT is investigating an issue with power at Monarch Pediatrics on New Ballas Rd. The entire building is currently without power and Ameren has acknowledged that they are working on restoring service. Technical teams are working on activating hot spot devices to allow the team to access patient schedules and other resources until power has been restored.
Teams are working to resolve the issue. Please call 314-933-3333 if you have any questions. We appreciate your patience as we work to restore service.
Posted May 20, 2026 - 08:03 CDT
This incident affected: Facilities - Power, Water, Etc.