Vendor Service Outage: Canvas

Incident Report for Washington University - IT

Monitoring

WashU IT has confirmed that Canvas services are being restored. Out of an abundance of caution, WashU will temporarily disable user access to Canvas. Additional information will be communicated on Friday 5/8 ~9:30am.

Please call 314-933-3333 if you have any questions. We appreciate your patience as we work to restore service.
Posted May 07, 2026 - 22:37 CDT

Update

WashU IT is investigating reports that Canvas is unavailable. Canvas vendor Instructure has posted a notification on their Status Page that they are experiencing a service outage. Additional details are available here: https://status.instructure.com/. Our next update will be on Friday 5/8 ~9am or when the vendor provides an updated status.

Teams are working to resolve the issue. Please call 314-933-3333 if you have any questions. We appreciate your patience as we work to restore service.
Posted May 07, 2026 - 18:01 CDT

Investigating

WashU IT is investigating reports that Canvas is unavailable. Canvas vendor Instructure has posted a notification on their Status Page that they are experiencing a service outage. Additional details are available here: https://status.instructure.com/

Teams are working to resolve the issue. Please call 314-933-3333 if you have any questions. We appreciate your patience as we work to restore service.
Posted May 07, 2026 - 15:48 CDT
This incident affects: Teaching & Learning (Canvas).