WashU IT Engineers and the vendor, KnowledgeLake, have resolved the issue in which KnowledgeLake users either could not log on or were presented with a blank screen. If you continue to experience further issues, please contact us at 314-933-3333.
We appreciate your patience during this incident.
Posted Mar 16, 2026 - 16:37 CDT
Monitoring
KnowledgeLake has performed a system restore as a possible fix for the issue in which KnowledgeLake users either were unable to log on or were presented with a blank screen upon logging on. Initial reports are that this is resolving the issues. Teams are continuing to monitor the service. If you continue to experience further issues, please contact us at 314-933-3333.
We appreciate your patience during this incident.
Posted Mar 16, 2026 - 14:55 CDT
Identified
Washington University IT and KnowledgeLake have identified the issue either preventing KnowledgeLake users from logging on or being presented a blank screen upon successful login. KnowledgeLake has restored functionality to several individuals and is developing a plan to address the remainder of the population.
Teams are working to resolve the issue. Please call 314-933-3333 if you have any questions. We appreciate your patience as we work to restore service.
Posted Mar 16, 2026 - 11:52 CDT
Update
WashU IT and the vendor, KnowledgeLake, continue to investigate the issue in which KnowledgeLake users either cannot log in or are presented with a blank screen upon successful login.
Teams are working to resolve the issue. Please call 314-933-3333 if you have any questions. We appreciate your patience as we work to restore service.
Posted Mar 16, 2026 - 10:33 CDT
Investigating
WashU IT is investigating an issue with KnowledgeLake in which users are unable to log in. WashU IT is working with the vendor to investigate.
Teams are working to resolve the issue. Please call 314-933-3333 if you have any questions. We appreciate your patience as we work to restore service.