Vendor Service Outage Advisory: Copilot

Incident Report for Washington University - IT

Resolved

Microsoft has resolved the issues affecting Copilot. If you continue to experience further issues, please contact us at 314-933-3333.

We appreciate your patience during this incident.
Posted May 29, 2026 - 14:59 CDT

Investigating

WashU IT has received notification from Microsoft that they are experiencing service issues with their Copilot service, affecting multiple customers including WashU. Microsoft advised that users will receive errors when attempting to interact with Microsoft Copilot. This issue affects Copilot experiences across all Microsoft 365 productivity apps and services.

Please call 314-933-3333 if you have any questions. We appreciate your patience as we work to restore service.
Posted May 29, 2026 - 12:31 CDT
This incident affected: Communications & Collaboration (Office 365).