BJC Service Outage: Baxter IV Pumps Not Connecting to Wifi

Incident Report for Washington University - IT

Resolved

BJC has restored service to the Baxter pumps which were having difficulty connecting to wifi. If you continue to experience further issues, please contact us at 314-933-3333.

We appreciate your patience during this incident.
Posted Feb 18, 2026 - 16:57 CST

Investigating

BJC has started a P1 outage call due to Baxter IV pumps not connecting to wifi. Troubleshooting is in progress as well as verification of which locations are impacted.

Teams are working to resolve the issue. Please call 314-933-3333 if you have any questions. We appreciate your patience as we work to restore service.
Posted Feb 18, 2026 - 15:15 CST
This incident affected: BJC Devices and Services (BJC Network Connectivity).