WashU IT Engineers have resolved the issue affecting network connectivity at Mid Campus Center. If you continue to experience further issues, please contact us at 314-933-3333.
We appreciate your patience during this incident.
Posted Aug 17, 2026 - 15:57 CDT
Update
WashU IT is investigating an issue with network connectivity at Mid Campus Center (MCC). Technical teams are troubleshooting the issue with Cisco support and there is a change being scheduled for later today to swap out some network equipment.
Please call 314-933-3333 if you have any questions. We appreciate your patience as we work to restore service.
Posted Aug 17, 2026 - 14:04 CDT
Update
WashU IT is investigating an issue with network connectivity at Mid Campus Center (MCC). Technical teams are still working to troubleshoot the issue and are opening a support case with Cisco.
Please call 314-933-3333 if you have any questions. We appreciate your patience as we work to restore service.
Posted Aug 17, 2026 - 12:49 CDT
Investigating
WashU IT is investigating an issue with network connectivity at Mid Campus Center (MCC). Technical teams have observed some network instability and are planning to perform an equipment reboot at 12pm to resolve the issue. There should be little to no additional user impact from the reboot.
Please call 314-933-3333 if you have any questions. We appreciate your patience as we work to restore service.