BJC P1 - Cloverleaf Not Relaying Documents Between Onbase and Epic (East Region)

Incident Report for Washington University - IT

Resolved

BJC IT has resolved the issue affecting Cloverleaf.. If you continue to experience further issues, please contact us at 314-933-3333.

We appreciate your patience during this incident.
Posted Jun 10, 2026 - 11:33 CDT

Investigating

BJC IT is investigating an issue with Cloverleaf in East Region. Due to a scheduled change last evening, Cloverleaf is not relaying documents between Onbase and Epic.

Teams are working to resolve the issue. Please call 314-933-3333 if you have any questions. We appreciate your patience as we work to restore service.
Posted Jun 10, 2026 - 10:49 CDT
This incident affected: BJC Devices and Services (BJC Clinical Applications).