Vendor Service Advisory: Legacy Outlook for Mac Issues
Incident Report for Washington University - IT
Resolved
Microsoft has resolved the issues affecting the Legacy Outlook client for Macs. If you continue to experience further issues, please contact us at 314-933-3333.

We appreciate your patience during this incident.
Posted Mar 26, 2024 - 08:46 CDT
Update
Microsoft is aware of an issue affecting Exchange Online (Email) access for Legacy Outlook for Mac for many of their customers. Microsoft has finished internal testing of an additional fix for this issue. They expect to begin deploying the fix to their infrastructure by the time they send their next update on Monday, 3/25 around 2:30pm.

Please call 314-933-3333 if you have any questions. We appreciate your patience during this Incident.
Posted Mar 23, 2024 - 14:22 CDT
Update
Microsoft is aware of an issue affecting Exchange Online (Email) access for Legacy Outlook for Mac for many of their customers. Microsoft has identified additional factors causing the issue from what they previously knew about. Due to this complication, Microsoft has to go back and develop an additional fix to deploy out through their environment. They expect to have the next status update around 1pm on Saturday 3/23.

Please call 314-933-3333 if you have any questions. We appreciate your patience during this Incident.
Posted Mar 22, 2024 - 17:27 CDT
Update
Microsoft is aware of an issue affecting Exchange Online (Email) access for Legacy Outlook for Mac for many of their customers. Microsoft is in the process of deploying a fix to resolve the issue. Per the latest update from Microsoft, they currently expect the issue to be resolved by 5pm on Friday, 3/22.

Please call 314-933-3333 if you have any questions. We appreciate your patience during this Incident.
Posted Mar 22, 2024 - 00:03 CDT
Identified
Microsoft is aware of an issue affecting Exchange Online (Email) access for Legacy Outlook for Mac for many of their customers. Microsoft is in the process of deploying a fix to resolve the issue.

Users may be unable to connect to Exchange Online, resulting in inbound and outbound email not delivering.

Users may access Outlook Web Access as a workaround via https://outlook.office.com/owa/?realm=wustl.edu.
Posted Mar 21, 2024 - 14:21 CDT
This incident affected: Communications & Collaboration (Email).